mirror of
https://github.com/hyprwm/hyprcursor.git
synced 2024-11-16 18:25:58 +01:00
39 lines
961 B
Nix
39 lines
961 B
Nix
{
|
|
description = "The hyprland cursor format, library and utilities";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
systems.url = "github:nix-systems/default-linux";
|
|
|
|
hyprlang = {
|
|
url = "github:hyprwm/hyprlang";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
systems,
|
|
...
|
|
} @ inputs: let
|
|
inherit (nixpkgs) lib;
|
|
eachSystem = lib.genAttrs (import systems);
|
|
pkgsFor = eachSystem (system:
|
|
import nixpkgs {
|
|
localSystem.system = system;
|
|
overlays = with self.overlays; [default];
|
|
});
|
|
in {
|
|
overlays = import ./nix/overlays.nix {inherit inputs lib;};
|
|
|
|
packages = eachSystem (system: {
|
|
default = self.packages.${system}.hyprcursor;
|
|
inherit (pkgsFor.${system}) hyprcursor;
|
|
});
|
|
|
|
checks = eachSystem (system: self.packages.${system});
|
|
|
|
formatter = eachSystem (system: pkgsFor.${system}.alejandra);
|
|
};
|
|
}
|