xdg-desktop-portal-hyprland/nix/default.nix

73 lines
1.3 KiB
Nix

{
lib,
stdenv,
makeWrapper,
meson,
ninja,
pkg-config,
libdrm,
mesa,
pipewire,
sdbus-cpp,
systemd,
wayland-protocols,
wayland-scanner,
qtbase,
qttools,
qtwayland,
wrapQtAppsHook,
hyprland,
slurp,
hyprland-protocols,
wayland,
version ? "git",
}:
stdenv.mkDerivation {
pname = "xdg-desktop-portal-hyprland";
inherit version;
src = ../.;
nativeBuildInputs = [
meson
ninja
pkg-config
wayland-scanner
makeWrapper
wrapQtAppsHook
];
buildInputs = [
hyprland-protocols
libdrm
mesa
pipewire
qtbase
qttools
qtwayland
sdbus-cpp
systemd
wayland
wayland-protocols
];
dontWrapQtApps = true;
postInstall = ''
wrapProgramShell $out/bin/hyprland-share-picker \
"''${qtWrapperArgs[@]}" \
--prefix PATH ":" ${lib.makeBinPath [slurp hyprland]}
wrapProgramShell $out/libexec/xdg-desktop-portal-hyprland \
--prefix PATH ":" ${lib.makeBinPath [(placeholder "out")]}
'';
meta = with lib; {
homepage = "https://github.com/hyprwm/xdg-desktop-portal-hyprland";
description = "xdg-desktop-portal backend for Hyprland";
license = licenses.bsd3;
maintainers = with maintainers; [fufexan];
platforms = platforms.linux;
};
}