mirror of
https://github.com/NotAShelf/neovim-flake.git
synced 2024-11-07 21:45:59 +01:00
24 lines
439 B
Nix
24 lines
439 B
Nix
{
|
|
config,
|
|
lib,
|
|
...
|
|
}: let
|
|
inherit (lib) mkIf nvim;
|
|
|
|
cfg = config.vim.ui.illuminate;
|
|
in {
|
|
config = mkIf cfg.enable {
|
|
vim.startPlugins = ["vim-illuminate"];
|
|
|
|
vim.luaConfigRC.vim-illuminate = nvim.dag.entryAnywhere ''
|
|
require('illuminate').configure({
|
|
filetypes_denylist = {
|
|
'dirvish',
|
|
'fugitive',
|
|
'NvimTree',
|
|
'TelescopePrompt',
|
|
},
|
|
})
|
|
'';
|
|
};
|
|
}
|